扫地机器人论坛 | 爸爸乐轻松_扫地机器人的百科全书

 找回密码
 没有帐号?
楼主: starmoon

[求助] BotVac 充电时提示“请打开我的垃圾盒并按下按钮开关”   [复制链接]

Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24

帖子
518
电量
3497
在线时间
645 小时
注册时间
2014-7-7

SHOW IT 我是麦霸 热心会员 第一次“设精” 大海啊全是水 我喜欢这儿 DIY达人 精英用户 产品评测组

发表于 2015-1-19 17:45:33 |显示全部楼层
从充电和放电时间来看,电池容量基本没有问题,可能问题出在温度开关和温度传感器上,还没有解拆测量,并电阻的方法也想到了,稍后试一下,根据读数差,初步准备并50k或47k

Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24

帖子
518
电量
3497
在线时间
645 小时
注册时间
2014-7-7

SHOW IT 我是麦霸 热心会员 第一次“设精” 大海啊全是水 我喜欢这儿 DIY达人 精英用户 产品评测组

发表于 2015-1-20 17:33:25 |显示全部楼层
进展,拆解电池

1. 温度传感器并50k电阻 -> 不能排除故障
2. 温度保险短路(跳过) -> 不能排除故障


20150119_230403_调整大小.jpg

Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24

帖子
718
电量
15657
在线时间
432 小时
注册时间
2014-11-19

我是麦霸 热心会员 第一次“设精” 大海啊全是水 我喜欢这儿 DIY达人 什么都难不住我! 精英用户 产品评测组

发表于 2015-1-20 22:24:41 |显示全部楼层
starmoon 发表于 2015-1-20 17:33
进展,拆解电池

1. 温度传感器并50k电阻 -> 不能排除故障

那还是没有确认问题喽?

Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24

帖子
518
电量
3497
在线时间
645 小时
注册时间
2014-7-7

SHOW IT 我是麦霸 热心会员 第一次“设精” 大海啊全是水 我喜欢这儿 DIY达人 精英用户 产品评测组

发表于 2015-1-20 22:54:27 |显示全部楼层
xmysz 发表于 2015-1-20 22:24
那还是没有确认问题喽?

确定是电池问题,但不知道是哪里问题,电池电量和充电过程看上去都没问题,插头接触也检查过,温度传感器和温度保险看上去也挺正常,没有办法动态监测,不知道机器判断依据。

这块电池放在其它机里一样显示同样问题,其它机器电池放在我的机上,一切正常。

工程师

专业维修工程师

Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24

帖子
173
电量
1530
在线时间
420 小时
注册时间
2013-10-1

我是麦霸 热心会员 我喜欢这儿 DIY达人 什么都难不住我! 工程师

发表于 2015-1-20 23:03:14 |显示全部楼层
楼主已经发现是电池出问题,可以用以下方法排查:把原机的吸风扇插头拨出,+ —线与电池的红色线和黑色线相连,此时风扇应转动,并且有2.94A的电流,再用万用表,测每节电池的电压,应该都有1.3V,如果有一节电池电压不正常,这节电池就是问题,或者是这节的焊点虚焊。另外,如果电池组的热缩胶拆下后,可用一般的多股花线,抽一股线,在一节电池上短接,铜线会立即发红烧掉,(1200MAH以上的镍氢电池都可以这样简单试它的容量)1,单节电池问题,2,焊点问题。用五笔打这几个字,用了一个小时,修电池,早就修好了。

Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24

帖子
518
电量
3497
在线时间
645 小时
注册时间
2014-7-7

SHOW IT 我是麦霸 热心会员 第一次“设精” 大海啊全是水 我喜欢这儿 DIY达人 精英用户 产品评测组

发表于 2015-1-20 23:08:28 |显示全部楼层
准备拆下用电池检测仪/定容仪每节测试

从能强制开始清扫和续航性能没明显变小判断,电池放电能力基本正常,问题还是出在充电阶段(或者保压阶段),充电电流应该是小于放电电流的。

工程师

专业维修工程师

Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24

帖子
173
电量
1530
在线时间
420 小时
注册时间
2013-10-1

我是麦霸 热心会员 我喜欢这儿 DIY达人 什么都难不住我! 工程师

发表于 2015-1-21 00:15:18 |显示全部楼层
NEATO和BOTVAC的充电结构是一样的,Q31为大电流充电,Q32为涓流保压,它们之间的转换,必须满足充电压和电池 的并联电压大于18.60V,此时,充电指示停止,它的取样是通过分压电阻,降压到3V到A/D到MCU,你不让它充电指示停止,它是不让你起动机器工作的,至于你‘强制开始清扫’是你的电池电压接近18.60V,并且把它从充电座分隔,从启电源开关,它才能‘强制开始清扫’。

Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24

帖子
518
电量
3497
在线时间
645 小时
注册时间
2014-7-7

SHOW IT 我是麦霸 热心会员 第一次“设精” 大海啊全是水 我喜欢这儿 DIY达人 精英用户 产品评测组

发表于 2015-1-21 01:52:04 |显示全部楼层
不是那个强制清扫,是出现错误提示的快速恢复,电池实际已经是充满的,是从充电座上启动的

Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24

帖子
755
电量
2853
在线时间
883 小时
注册时间
2014-9-21

我是麦霸 热心会员 板猪?版猪?! 第一次“设精” 大海啊全是水 我喜欢这儿 DIY达人 什么都难不住我! 精英用户 工程师 产品评测组

发表于 2015-1-24 06:06:33 |显示全部楼层
不知楼主电池测试的结果如何了

Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24

帖子
518
电量
3497
在线时间
645 小时
注册时间
2014-7-7

SHOW IT 我是麦霸 热心会员 第一次“设精” 大海啊全是水 我喜欢这儿 DIY达人 精英用户 产品评测组

发表于 2015-1-24 13:11:32 来自手机 |显示全部楼层
还没测,买了个4200的兼容电池,现在机器一切正常了,就有点懒了
您需要登录后才可以回帖 登录 | 没有帐号?

Archiver|手机版|扫地机器人论坛 | 爸爸乐轻松

GMT+8, 2018-10-23 03:15 , Processed in 0.083655 second(s), 6 queries , Gzip On, Memcache On.

Powered by Discuz! X3.2

© 2001-2017 Comsenz Inc.

回顶部