扫地机器人论坛 | 爸爸乐轻松_扫地机器人的百科全书

 找回密码
 没有帐号?
查看: 5437|回复: 19

[求助] Neato BotVac 70e改装锂电池组的困惑 [复制链接]

Rank: 3Rank: 3

帖子
17
电量
58
在线时间
29 小时
注册时间
2015-6-10
发表于 2015-7-27 21:54:11 |显示全部楼层
本帖最后由 田先生田先生 于 2015-7-28 20:50 编辑

       最近买入了一台Neato BotVac 70e扫地机器人,考虑到一是标配的12V、3600mAh的镍氢电池组只有半年到一年的寿命,二是我家有140多平方米,需要清扫部分面积后再充电一次才能清扫完,比较耗费时间,因此打算自制一个锂电池组,用于Neato BotVac 70e扫地机器人。
       自制前打开了机器人标配的12V、3600mAh的镍氢电池组,看见它是由10节镍氢电池串联组成,在串联的电池之间串联了一个型号为SEKI ST-22 130C的温度开关,另外放置了一个大约为10K的热敏电阻,将其两只脚接在连接器上,再与主机电路相连接。
       我自制的锂电池组采用9节NCR18650B锂电池组成,3并3串,刚好能够放入Neato BotVac 70e扫地机器人的电池仓。这样,电压与标配的镍氢电池组相仿,容量却达到了10200mAh。我自制的锂电池组中没有串联温度开关,但是同样放置了一个10K的热敏电阻,将其两只脚接在连接器上,再与主机电路相连接。充电电路打算不采用原机标配的充电电路,另外购置一个12.6V的锂电池充电器为锂电池组充电。
       开始时,为了保护锂电池,我在自制的电池组中接入了一个3串的锂电池保护板,组装好了以后试机,机子的显示屏上总是首先出现“请按下"确定" 以重新启动 电池问题0008”,接着变成为“请按下"确定" 以重新启动 电池问题8004”,最后机子响了两声,显示屏停止显示,关机,除此之外机子没有任何反应。考虑到接入的锂电池保护板可能致使机子不能正常工作,于是拆下了锂电池保护板,试机的情况还是相同。
       对此我感到很困惑,不知道是不是Neato BotVac 70e扫地机器人的内部控制电路做了一些设置,造成了我的努力不能实现,还是我的设计存在不足之处。
       特向版主、各位大侠请教。

点评

admin  先把锂电池充电到12v左右再看  发表于 2015-7-27 22:28:11

Rank: 3Rank: 3

帖子
17
电量
58
在线时间
29 小时
注册时间
2015-6-10
发表于 2015-7-27 23:00:29 |显示全部楼层
admin  先把锂电池充电到12v左右再看  发表于 27 分钟前

把锂电池充电到了12v多,试机结果相同。

点评

admin  检查电阻反馈阻值,上电自动关机除了电压过高还有就是温度过高(也就是阻值低于3k)或检测不到温敏电阻阻值  发表于 2015-7-27 23:07:09

超级版主

评测中寻找快乐

Rank: 28Rank: 28Rank: 28Rank: 28Rank: 28Rank: 28Rank: 28

帖子
7329
电量
20136
在线时间
7769 小时
注册时间
2013-7-21

SHOW IT 我是麦霸 热心会员 第一次“设精” 大海啊全是水 我喜欢这儿 DIY达人 什么都难不住我! 精英用户 产品评测组

发表于 2015-7-28 10:39:40 来自手机 |显示全部楼层
田先生田先生 发表于 2015-7-27 23:00
把锂电池充电到了12v多,试机结果相同。

neato有断点续扫功能,就算一次扫不完,接着来一次就行了,自己弄锂电池组一个有风险,2来充电还麻烦!我觉得没必要弄!

Rank: 3Rank: 3

帖子
17
电量
58
在线时间
29 小时
注册时间
2015-6-10
发表于 2015-7-28 16:54:02 |显示全部楼层
点评admin  检查电阻反馈阻值,上电自动关机除了电压过高还有就是温度过高(也就是阻值低于3k)或检测不到温敏电阻阻值  发表于 昨天 23:07
已经检查温敏电阻值,上电前和自动关机后的电阻值均为8.33K。

Rank: 3Rank: 3

帖子
17
电量
58
在线时间
29 小时
注册时间
2015-6-10
发表于 2015-7-28 16:56:31 |显示全部楼层
点评admin  检查电阻反馈阻值,上电自动关机除了电压过高还有就是温度过高(也就是阻值低于3k)或检测不到温敏电阻阻值  发表于 昨天 23:07

已经检查温敏电阻值,上电前和自动关机后的电阻值均为8.33K。

Rank: 12Rank: 12Rank: 12

帖子
304
电量
3301
在线时间
578 小时
注册时间
2015-7-17

SHOW IT 我是麦霸 热心会员 第一次“设精” 我喜欢这儿 大海啊全是水

发表于 2015-7-28 16:57:30 |显示全部楼层
容量却达到了10200mAh

Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24Rank: 24

帖子
518
电量
3497
在线时间
645 小时
注册时间
2014-7-7

SHOW IT 我是麦霸 热心会员 第一次“设精” 大海啊全是水 我喜欢这儿 DIY达人 精英用户 产品评测组

发表于 2015-7-28 16:59:21 |显示全部楼层
有人已经试过了,改造工作量太大,不值得,多处检测都和锂电使用不兼容

Rank: 3Rank: 3

帖子
17
电量
58
在线时间
29 小时
注册时间
2015-6-10
发表于 2015-7-28 17:52:21 |显示全部楼层
有人已经试过了,改造工作量太大,不值得,多处检测都和锂电使用不兼容

改造工作量太大,不害怕,只要能够成功,长远来看还是值得的。有这方面的帖子吗,请介绍一下,谢谢了。

超级版主

科技改变生活

Rank: 28Rank: 28Rank: 28Rank: 28Rank: 28Rank: 28Rank: 28

帖子
16367
电量
29586
在线时间
4899 小时
注册时间
2012-3-5

资深"丸"家 我是麦霸 热心会员 板猪?版猪?! 第一次“设精” 大海啊全是水 我喜欢这儿 DIY达人 什么都难不住我! 精英用户

发表于 2015-7-28 18:12:10 |显示全部楼层
LZ做个测试,外接DC IN电压在13-14V左右并联10K电阻模拟NTC 10K再开机,看看会不会自动关机,如果还是自动关机证明你的插头可能有问题存在接触不良,正常情况下主机只会提示请充电不会报电池错误后自动关机,如果不自动关机证明你的电池有问题,两种情况Neato会自动关机:1、电池超压,例如电压输入DC 16V,2、温敏电阻检测不到或者严重高温低阻值

Rank: 3Rank: 3

帖子
17
电量
58
在线时间
29 小时
注册时间
2015-6-10
发表于 2015-7-28 20:37:53 |显示全部楼层
LZ做个测试,外接DC IN电压在13-14V左右并联10K电阻模拟NTC 10K再开机,看看会不会自动关机,如果还是自动关机证明你的插头可能有问题存在接触不良,正常情况下主机只会提示请充电不会报电池错误后自动关机,如果不自动关机证明你的电池有问题,两种情况Nea...

谢谢超版。按照你的建议,我将原机标配的电源和温敏电阻接在我购置的插头上,第一次测试,开机后机子显示“电量不足,需要充电”,以后测试显示屏上都是首先出现“请按下"确定" 以重新启动 电池问题0008”,接着变成为“请按下"确定" 以重新启动 电池问题8004”,最后显示屏停止显示,关机。看来我购置的插头是有问题(我是分别买了插头的壳和端子,子机焊接安装的),有时接触到了,有时又接触不良。现在我首先要解决插头问题。但是超版说了“如果不自动关机证明你的电池有问题”,我买的9节新的NCR18650B锂电池3并3串组成的电池组(现在没有加3串的电池保护板),用万用表测量现在的电压是12.3V,请超版帮我分析一下,电池可能出现哪些方面的问题。谢谢。
您需要登录后才可以回帖 登录 | 没有帐号?

Archiver|手机版|扫地机器人论坛 | 爸爸乐轻松

GMT+8, 2019-3-20 15:11 , Processed in 0.105157 second(s), 5 queries , Gzip On, Memcache On.

Powered by Discuz! X3.2

© 2001-2017 Comsenz Inc.

回顶部